I get the following when compiling a flutter app:
Because firebase_crashlytics >=2.8.4 depends on firebase_core_platform_interface ^4.4.3 and assembly depends on firebase_core_platform_interface 4.4.1, firebase_crashlytics >=2.8.4 is forbidden.
The challenge is I added the firebase crashlytics in part of the app; the fire_base_core_platform version is determined elsewhere and I do not have the ability to change that package or that version.
How can I set up the appropriate version for crashlytics (I don't have a hard requirement to use that version) that doesn't collide with the other dependencies?
NOTE: What I am doing is going through earlier tags for earlier versions in the repo for firebase_crashlytics, and checking the pubspec file for what version is used to find one that matches....feels like a cheat, but wondering if there's a better way.