Recently reinstalled my MacBook, and upgraded to Big Sur (11.0.1)

Installed Intellij Android Studio v4.1

Can't seem to set the Visual code folding guide to 120. It's limited to 80. Any suggestions on how to fix this would be greatly appreciated.

enter image description here

$ flutter doctor -v
[✓] Flutter (Channel stable, 1.22.4, on macOS 11.0.1 20B50 darwin-x64, locale en-US)
    • Flutter version 1.22.4 at /Users/agautam/tools/flutter
    • Framework revision 1aafb3a8b9 (3 weeks ago), 2020-11-13 09:59:28 -0800
    • Engine revision 2c956a31c0
    • Dart version 2.10.4

[✓] Android toolchain - develop for Android devices (Android SDK version 30.0.2)
    • Android SDK at /Users/agautam/Library/Android/sdk
    • Platform android-30, build-tools 30.0.2
    • ANDROID_HOME = /Users/agautam/Library/Android/sdk
    • Java binary at: /Applications/Android Studio.app/Contents/jre/jdk/Contents/Home/bin/java
    • Java version OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b3-6915495)
    • All Android licenses accepted.

[✓] Xcode - develop for iOS and macOS (Xcode 12.2)
    • Xcode at /Applications/Xcode.app/Contents/Developer
    • Xcode 12.2, Build version 12B45b
    • CocoaPods version 1.10.0

[!] Android Studio (version 4.1)
    • Android Studio at /Applications/Android Studio.app/Contents
    ✗ Flutter plugin not installed; this adds Flutter specific functionality.
    ✗ Dart plugin not installed; this adds Dart specific functionality.
    • Java version OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b3-6915495)

[✓] VS Code (version 1.51.1)
    • VS Code at /Applications/Visual Studio Code.app/Contents
    • Flutter extension version 3.16.0

[✓] Connected device (2 available)
    • sdk gphone x86 (mobile)    • emulator-5554                        • android-x86 • Android 11 (API 30) (emulator)
    • iPhone 12 Pro Max (mobile) • 5413E7E2-693C-4635-9FB8-AD297FEDB50C • ios         • com.apple.CoreSimulator.SimRuntime.iOS-14-2 (simulator)


Solution 1: Ajay Gautam

Found that Dart editor does not support system/root level setting. Here is the one for Dart (This fixed it for me):

enter image description here


Solution 2: Randal Schwartz

The dart community has mainly agreed that the output of dartfmt is canonical. (This ensures that git doesn't show false changes simply from reformatting.) It is therefore somewhat futile to try to tweak anything, except by filing issues against dartfmt. :)