I am working on a project which needs some dependencies that i added in pubspec.yaml

  dependencies:

  flutter:

    sdk: flutter

  google_sign_in: "^0.3.1"

  firebase_auth: "^0.2.3"

  http: "^0.11.3+16"

  # The following adds the Cupertino Icons font to your application.

  # Use with the CupertinoIcons class for iOS style icons.

  cupertino_icons: ^0.1.0

  flutter_markdown: "^0.1.5"

  url_launcher: "^3.0.1"

  share: "^0.4.0"

when i click on Packages Get in pubspec.yaml it shows this

C:\Flutter\bin\flutter.bat --no-color packages get

Running "flutter packages get" in list_drag_drop...

Process finished with exit code 0

And when i Click on Get Dependencies in pubspec.yaml it shows this

Working dir: D:\Flutter proj downloaded\list_drag_drop

C:\Flutter\bin\cache\dart-sdk\bin\pub.bat get

Resolving dependencies...

Because share 0.4.0 requires the Flutter SDK and no versions of share match>0.4.0 <0.5.0, share ^0.4.0 is forbidden.

So, because list_drag_drop depends on share ^0.4.0, version solving failed.

Flutter users should run flutter packages get instead of pub get. Process finished with exit code 1

And when I Run my Project it stucks on Resolving Dependencies. Please someone help , i have googled it but cannot resolve issue . i have flutter and dart plugin installed.