I was using contacts service a flutter package, and till now it worked perfectly. But after updating flutter to the new version it crashes the app.

dependencies:
  contacts_service: ^0.3.2

The following error is given:

E/AndroidRuntime(19843): java.lang.RuntimeException: An error occurred while executing doInBackground()
E/AndroidRuntime(19843):    at android.os.AsyncTask$3.done(AsyncTask.java:354)
E/AndroidRuntime(19843):    at java.util.concurrent.FutureTask.finishCompletion(FutureTask.java:383)
E/AndroidRuntime(19843):    at java.util.concurrent.FutureTask.setException(FutureTask.java:252)
E/AndroidRuntime(19843):    at java.util.concurrent.FutureTask.run(FutureTask.java:271)
E/AndroidRuntime(19843):    at android.os.AsyncTask$SerialExecutor$1.run(AsyncTask.java:245)
E/AndroidRuntime(19843):    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
E/AndroidRuntime(19843):    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
E/AndroidRuntime(19843):    at java.lang.Thread.run(Thread.java:764)
E/AndroidRuntime(19843): Caused by: java.lang.NullPointerException: Attempt to invoke virtual method 'java.lang.String java.lang.String.toLowerCase()' on a null object reference
E/AndroidRuntime(19843):    at flutter.plugins.contactsservice.contactsservice.Contact.compareTo(Contact.java:94)
E/AndroidRuntime(19843):    at flutter.plugins.contactsservice.contactsservice.ContactsServicePlugin$GetContactsTask$1.compare(ContactsServicePlugin.java:175)
E/AndroidRuntime(19843):    at flutter.plugins.contactsservice.contactsservice.ContactsServicePlugin$GetContactsTask$1.compare(ContactsServicePlugin.java:172)
E/AndroidRuntime(19843):    at java.util.TimSort.countRunAndMakeAscending(TimSort.java:355)
E/AndroidRuntime(19843):    at java.util.TimSort.sort(TimSort.java:234)
E/AndroidRuntime(19843):    at java.util.Arrays.sort(Arrays.java:1498)
E/AndroidRuntime(19843):    at java.util.ArrayList.sort(ArrayList.java:1470)
E/AndroidRuntime(19843):    at java.util.Collections.sort(Collections.java:201)
E/AndroidRuntime(19843):    at flutter.plugins.contactsservice.contactsservice.ContactsServicePlugin$GetContactsTask.doInBackground(ContactsServicePlugin.java:178)
E/AndroidRuntime(19843):    at flutter.plugins.contactsservice.contactsservice.ContactsServicePlugin$GetContactsTask.doInBackground(ContactsServicePlugin.java:137)
E/AndroidRuntime(19843):    at android.os.AsyncTask$2.call(AsyncTask.java:333)
E/AndroidRuntime(19843):    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
E/AndroidRuntime(19843):    ... 4 more

Firstly I ask for contacts permission and all, and after that I do the fetching:

 phoneContacts = await ContactsService.getContacts();

I don't know where that lowerCase is coming, I deleted all the .toLowerCase in my project but still the error isn't changing. What can I do?