I try to build a realese signed apk of my app, but have two errors. First is thrown by gradle, it is like missing some files, second comes from firebase messaging plugin. I have already set CompileSdkVersion to 28 in build.gradle! I'm running flutter clean every time before building with flutter build apk --split-per-abi command. By the way, app bundle builds with no problems. Here is the output of terminal

Running "flutter pub get" in lock_ui...                             1,1s
Note: C:\Flutter\flutter\.pub-cache\hosted\pub.dartlang.org\android_intent-0.3.7+4\android\src\main\java\io\flutter\plugins\androidintent\MethodCallHand
lerImpl.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Note: C:\Flutter\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_blue-0.7.2\android\src\main\java\com\pauldemarco\flutter_blue\FlutterBluePlugin.java
 uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: C:\WheelKeep\lock_ui\build\flutter_blue\generated\source\proto\release\javalite\com\pauldemarco\flutter_blue\Protos.java uses unchecked or unsafe
operations.
Note: Recompile with -Xlint:unchecked for details.
Note: C:\Flutter\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_secure_storage-3.3.4\android\src\main\java\com\it_nomads\fluttersecurestorage\cipher
s\RSACipher18Implementation.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':shared_preferences:verifyReleaseResources'.
> A failure occurred while executing com.android.build.gradle.internal.tasks.Workers$ActionFacade
   > 1 exception was raised by workers:
     com.android.builder.internal.aapt.v2.Aapt2Exception: Android resource linking failed
     C:\Users\andri\.gradle\caches\transforms-2\files-2.1\3ae8acf77913112ba07cff775c9265b3\core-1.1.0\res\values\values.xml:142:5-173:25: AAPT: error: r
esource android:attr/fontVariationSettings not found.

     C:\Users\andri\.gradle\caches\transforms-2\files-2.1\3ae8acf77913112ba07cff775c9265b3\core-1.1.0\res\values\values.xml:142:5-173:25: AAPT: error: r
esource android:attr/ttcIndex not found.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 1m 42s
Running Gradle task 'assembleRelease'...
Running Gradle task 'assembleRelease'... Done                     103,6s
The built failed likely due to AndroidX incompatibilities in a plugin. The tool is about to try using Jetfier to solve the incompatibility.
Building plugin android_intent...
Running Gradle task 'assembleAarRelease'...
Running Gradle task 'assembleAarRelease'... Done                    2,4s
√ Built build\app\outputs\repo.
Building plugin firebase_core...
Running Gradle task 'assembleAarRelease'...
Running Gradle task 'assembleAarRelease'... Done                   74,0s

FAILURE: Build completed with 2 failures.

1: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':javaPreCompileRelease'.
> Could not resolve all files for configuration ':releaseCompileClasspath'.
   > Could not find com.google.firebase:firebase-bom:25.3.1.
     Required by:
         project :
   > Could not find com.google.firebase:firebase-core:.
     Required by:
         project :
   > Could not find androidx.annotation:annotation:1.1.0.
     Required by:
         project :

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
==============================================================================

2: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':generateReleaseRFile'.
> Could not resolve all files for configuration ':releaseRuntimeClasspath'.
   > Could not find com.google.firebase:firebase-bom:25.3.1.
     Searched in the following locations:
       - https://storage.googleapis.com/download.flutter.io/com/google/firebase/firebase-bom/25.3.1/firebase-bom-25.3.1.pom
       - https://storage.googleapis.com/download.flutter.io/com/google/firebase/firebase-bom/25.3.1/firebase-bom-25.3.1.jar
     Required by:
         project :
   > Could not find com.google.firebase:firebase-core:.
     Required by:
         project :
   > Could not find androidx.annotation:annotation:1.1.0.
     Searched in the following locations:
       - https://storage.googleapis.com/download.flutter.io/androidx/annotation/annotation/1.1.0/annotation-1.1.0.pom
       - https://storage.googleapis.com/download.flutter.io/androidx/annotation/annotation/1.1.0/annotation-1.1.0.jar
     Required by:
         project :

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
==============================================================================

* Get more help at https://help.gradle.org

BUILD FAILED in 1m 13s

The plugin firebase_core could not be built due to the issue above.


Solution 1: Bogdan Lonchuk

Try to use the older Firebase library version. I had the same issue and it disappeared after I downgraded the Firebase version.