I’m trying to use the following packages and the app keeps crashing

The libraries are :

  1. Fire base auth

    https://github.com/flutter/plugins/tree/master/packages/firebase_auth

  2. Google sign in

  3. Local auth


Solution 1: devsin

You should make firebase configuration first. You can use this codelabs: https://codelabs.developers.google.com/codelabs/flutter-firebase

Then you can add firabase_auth library to pubspec.yaml like this:

dependencies:
  flutter:
    sdk: flutter:
  firebase_auth:

I recommend you go step by step and don't mess up with google sign in now. Just use email and password authentication for now.