I have a flutter app that I am trying to build through bitrise.

and I keep getting a tonne of errors along the lines of `

 Error: The 'super-parameters' language feature is disabled for this library.
    Try removing the package language version or setting the language version to 2.17 or higher.
        super.key,
        ^^^^^

` and it is blocking me from analyzing, or building the app

now the issue is, I AM using flutter install with upgrade set to true , and have sdk target in my pubspec.yaml as

environment: sdk: ">=2.17.6 <3.0.0"


result of flutter install

I disabled the caching steps, and tried to create a new deployment pipeline, to no avail.


Solution 1: shuvo

In your workflow, add Flutter Install, Then set your desired flutter version on Input Variables sections's Flutter SDK git repository version field. e.g. 2.8.0.