According to this documentation https://dart.dev/get-dart, it is written in bold that As of Flutter 1.21, the Flutter SDK includes the full Dart SDK.

I know dart:mirrors has been removed from the dart shipped with the flutter sdk but this sentence above says that the full dart SDK is included. So how to enable dart:mirrors ?

enter image description here


Solution 1: Rohan Thacker

The dart:mirrors package is not available with flutter.

Do check these conversations on google groups and github for more info.

An alternative package called reflectable is available for reflection, however it has limitations at this time.