I'm trying to upgrade all the dependencies, but this error is still shown. I have tried to override them but shows a no privileges error. I already tried to run
flutter pub cache repair,
flutter pub get, and not sure if I need to delete the cache or maybe reinstall flutter in another file, please any suggest could help.
Because google_map_polyline >=0.0.4 <0.2.0 depends on google_maps_flutter ^0.5.21+4 and google_map_polyline <0.0.4 depends on google_maps_flutter ^0.5.19+2, google_map_polyline <0.2.0 requires google_maps_flutter ^0.5.19+2. And because google_map_polyline >=0.2.0 depends on google_maps_flutter ^0.5.21+6, every version of google_map_polyline requires google_maps_flutter ^0.5.19+2. So, because fletgo_user_app depends on both google_maps_flutter ^2.1.0 and google_map_polyline any, version solving failed. pub get failed (1; So, because fletgo_user_app depends on both google_maps_flutter ^2.1.0 and google_map_polyline any, version solving failed.) Process finished with exit code 1
Solution 1: Septian Dika
The error appears because google_map_polyline is set to 'any'. But the real problem appear because google_map_polyline is already discontinued.
I suggest you change the library and migrate using the flutter_polyline_points