I am working on an old project of flutter SDK 2.5.3. there are deprecated plugins call_number, ext_storage, flutter_rounded_date_picker, flutter_webview_plugin, permissions_plugin, shows as an warning. when I run the project it shows this error. I think this error is for the dio package. But, when I upgrade the plugin then that new dio package is depend on higher version of other packages. please tell me what I can do.

enter image description here