I am trying to build a flutter app on Codemagic but the build fails when installing dependencies. I have upgraded all dependencies in the pubspec.yaml file but I get the message below in Codemagic:

> flutter packages pub get

== Install Flutter dependencies ==Resolving dependencies...
The current Dart SDK version is 2.13.0.

Because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsafety <1.3.0, test >=1.16.0-nullsafety <1.16.0-nullsafety.18 requires typed_data >=1.3.0-nullsafety <1.3.0.
And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7, test >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.19-nullsafety.7.
And because test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1 and test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19, test >=1.15.5 <1.16.6 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.18+1 or 0.2.19-nullsafety.7 or 0.2.19.
And because every version of flutter_test from sdk depends on both typed_data 1.3.0 and test_api 0.3.0, flutter_test from sdk is incompatible with test >=1.15.5 <1.16.6.
And because test >=1.16.6 depends on yaml ^3.0.0 and flutter_launcher_icons 0.8.1 depends on yaml ^2.1.15, one of flutter_test any from sdk or test >=1.15.5 or flutter_launcher_icons 0.8.1 must be false.
And because no versions of flutter_launcher_icons match >0.8.1 <0.9.0 and tonnah depends on flutter_launcher_icons ^0.8.1, flutter_test from sdk is incompatible with test >=1.15.5.
So, because tonnah depends on both test ^1.15.7 and flutter_test any from sdk, version solving failed.
pub finished with exit code 1

Build failed :|
Failed to install dependencies

I have made a lot of changes to the code so I don't know where to start to look for a solution. I am not running any tests in Codemagic.

enter image description here

This is from flutter doctor:

Doctor summary (to see all details, run flutter doctor -v):
[√] Flutter (Channel stable, 2.0.5, on Microsoft Windows [Version
    10.0.19041.985], locale en-US)
[√] Android toolchain - develop for Android devices (Android SDK version 30.0.3)
[√] Chrome - develop for the web
[√] Android Studio (version 4.1.0)
[√] VS Code (version 1.56.2)
[√] Connected device (3 available)