Is it possible to compile a flutter package to import only the resulting binary in the project?

I'm new to flutter, I've been creating a few packages in flutter that would be imported in several other (flutter) project. This packages are independently versioned.<...

Communicate between two (and more) Flutter applications using flutter_bluetooth_serial

I'm developing Flutter app for Android, where I want to exchange some data between few instances of my app on different devices via Bluetooth. I'm using <a href="https...

Image is not saving in android gallery. whereas It is work properly on emultor

i'm making qr code maker/scanner app where, i am using <a href="https://pub.dev/packages/image_gallery_saver/example" rel="nofollow noreferrer">image_gallery_saver</a>...

How to access assets in package

<blockquote> The original question comes from flutter <a href="https://github.com/flutter/flutter/issues/32799" rel="nofollow noreferrer">issue 32799</a> </blockqu...

How to use two different packages together on the same data

I have this two packages which i want to use <a href="https://pub.dev/packages/flutter_linkify" rel="nofollow noreferrer">flutter_linkify</a> and <a href="https://pub....

How to pass data from one provider model to another?

I want use <code>provider</code> (<code>ChangeNotifierProvider</code>) and <code>ChangeNotifier</code> for manage app state. But how I can access state from one model...

How to change flutter project name and import names at all?

I tried to use the rename package to change my project name, and of course, also imports that have the project name itself, but the package has only change...

Location lat-lng getting wrong when using Yandex Map with flutter_map package

I am using flutter_map with yandex map like below. When I mark a location, Getting location lat and lon are wrong. So If I draw a polygon on the map, It drawn on wrong...

Is there a new version for the flutter tflite package?

I started working with Flutter and Dart lately, and I'm building a project using the tflite package. But when I want to build the app, even the demo app when just addi...

How to add string ranges in flutter line chart X-axis?

I am using charts_flutter package for line charts. I have to add some string ranges in X-axis, 0-1200,1200-3200,etc.How can I add this?

Importing the bloc package is not working

I am trying to <strong>import the bloc package</strong> so that I can create a <strong>cubit</strong> <pre><code>import 'package:meta/meta.dart'; import 'package:b...

Flutter packages own import target URI does not exist

I have a Flutter project that I started as a package in order for it to speak to platform specific native code. I've updated several packages lately along with flutt...

Unable to select image using flutter image picker on iOS simulator

I am learning how to select images from gallery. I have implemented flutter image picker for the same. But when I try to select the image in simulator, I am not able t...

dropdown_search Flutter not returning items when typing into search bar

I am using the dropdown_search version 0.4.3 package, I am able to populate the dropdown with items when clicking on the search bar , but when i start typing it isn't...

Visual Studio Code - Target of URI doesnt exist package:flutter/material.dart

I've just set up my Macbook for flutter development, So I downloaded flutter SDK, and placed it in my <strong>Documents</strong>. After, I set up my path variab...